Reparatur Technics SA-SX226 E-Piano

Der chaotische Hauptfaden

Moderatoren: Sven, Heaterman, TDI, Finger

Reparatur Technics SA-SX226 E-Piano

Beitragvon enebk » Mi 6. Dez 2017, 00:08

Hallo,
ich bräuchte mal einen Denkanstoß für die Reparatur eines E-Pianos, ein Technics SA-SX226. Fehler: Macht gar nichts mehr.

Sicherung/Trafo/Schalter sind in Ordnung, das Netzteil/Verstärkermodul produziert saubere +/-15V. Das eigentliche "Mainboard" sollte mit 5V arbeiten, dort liegen aber nur 1,3V an.
Woanders habe ich gelesen, dass der Pufferkondensator (Goldcap, 5,5V/1F) gerne mal ausläuft und die darunterliegenden Leiterbahnen zerfrisst; ist hier aber auch nicht der Fall.
So sieht das Teil aus:
Bild

Elektrotanya hat leider nur für andere Modelle ein Service Manual, am ehesten Vergleichbar ist dort das SA-SX111. Kommt jemand an das richtige SM?
Hier mal ein Auszug aus dessen Spannungsregelung:
Bild
Q1 ist ein 2SA1643, dieser ist auch auf meiner Platine (der schwarze, isolierte TO220) verbaut. Zumindest nach kurzer Laufzeit konnte ich keine Erwärmung irgendwo feststellen.

Zwei Theorien:
1) Die Spannungsregelung ist defekt
2) oder ein Bauteil produziert einen Kurzen.

Ich würde jetzt Transistor herausnehmen, Labornetzteil mit 5V und STROM ran -> Schauen ob die Kiste läuft oder welches Bauteil spektakulär PLÖP macht. Hoffentlich keiner der ICs....
Bessere Ideen?
enebk
 
Beiträge: 256
Registriert: Mi 14. Aug 2013, 18:51
Wohnort: Marl

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon Attimus » Mi 6. Dez 2017, 00:42

Also wenn der Schaltplan soweit übereinstimmt, dann würde ich als erstes Q1 und R1 auslöten (=Eingang auftrennen) und schauen ob da überhaupt Spannung kommt die geregelt werden könnte!
Benutzeravatar
Attimus
 
Beiträge: 117
Registriert: Mo 12. Aug 2013, 22:06
Wohnort: Oberösterreich

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon Bastelbruder » Mi 6. Dez 2017, 04:12

Die elementaren Bauteile dieses Schaltreglersschwingenden Linearreglers (es fehlt im Plan die Diode vom rechten Ende der Spule gegen Masse, ist das vielleicht die Schwarze hinter dem Transistor?) sind auf der Platine im Rechteck zwischen den blauen Elkos auch vorhanden. An D16 (=D1) müssen 5V anliegen. Bevor die Ausgangsspannung hochkommt schwingt da natürlich nix.
Vielleicht hat der Goldcap einen Kurzen?
Ich würde jedenfalls nicht mehr als 100 mA einspeisen, wenn (zuviel) Strom fließt läßt sich der Spannungsabfall auf den Leiterbahnen mit jedem billigen DVM nachverfolgen.
Bastelbruder
 
Beiträge: 3916
Registriert: Mi 14. Aug 2013, 18:28
Wohnort: drunt' am Neckar - km142,7

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon Gary » Mi 6. Dez 2017, 04:18

Miß die Spannung an der Z-Diode D16 und schau ob das mit dem übereinstimmt was drauf steht.
Gary
 
Beiträge: 1651
Registriert: Mo 12. Aug 2013, 01:02

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon enebk » Mi 6. Dez 2017, 21:44

Danke für die Tipps. Morgen komme ich wieder an das Gerät heran, dann gehts weiter.
enebk
 
Beiträge: 256
Registriert: Mi 14. Aug 2013, 18:51
Wohnort: Marl

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon Chefbastler » Mi 6. Dez 2017, 22:27

Ich vermute mal D12 hatt nen schlag weg. (Evtl. durch den Schaltregler davor) -> sollte im Betrieb warm werden wenn daran noch 1,3v abfallen.
Benutzeravatar
Chefbastler
 
Beiträge: 1331
Registriert: Mo 12. Aug 2013, 20:21
Wohnort: Südbayern

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon shaun » Mi 6. Dez 2017, 23:40

Ich hatte bei diesem Selbstschwinger in verschiedenen Technics-Pianos schon die unterschiedlichsten Fehler, interessanterweise war aber keine Havarie mit Kollateralschaden dabei. Offene Speicherdrossel, zu geringes Beta vom 2SA, leckende Z-Diode, tauber 1000u und kurzgeschlossene Keramic-Cs.
Der Transistor ist recht kritisch, mit einem BD244C zum Testen geht es, aber auf Dauer wird der zu heiss
shaun
 
Beiträge: 2194
Registriert: Mo 12. Aug 2013, 20:37

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon enebk » Fr 8. Dez 2017, 01:41

Heute war leider nur sehr wenig Zeit zum Basteln übrig. Immerhin habe ich einen hochohmigen Widerstand gefunden, zwei mal 2 Ohm sitzen zwischen "Vcc vom Power Supply" (direkt hinter dem Brückengleichrichter) und "Vcc vom Main Circuit". Beim SX-PX111 würde der defekte Widerstand R54 entsprechen:
Bild

Da ich gerade keinen passenden R da hatte habe ich jetzt die Platine mitgenommen. Zuerst einmal prüfen ob irgendwelche Bauteile zu viel Strom ziehen... -> Wochenende
enebk
 
Beiträge: 256
Registriert: Mi 14. Aug 2013, 18:51
Wohnort: Marl

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon Desinfector » Fr 8. Dez 2017, 08:06

Ich würde jetzt Transistor herausnehmen, Labornetzteil mit 5V und STROM ran -> Schauen ob die Kiste läuft oder welches Bauteil spektakulär PLÖP macht. Hoffentlich keiner der ICs....
Bessere Ideen?


Ja!
Nämlich anders rum:

Erstmal das Netzteil vom Rest abklemmen,
einen plausiblen Ersatzwiderstand ran und schauen,
ob das Netzteil die Leistung bringt.

wenn ja, hast Du schon mal ne gute Eingrenzung und musst kein Bauteil töten.

dann schauen ob Du die Halbleiter noch bekommst.

DANN erst evtl ein ex. Netzteil ran.

Woanders habe ich gelesen, dass der Pufferkondensator (Goldcap, 5,5V/1F) gerne mal ausläuft und die darunterliegenden Leiterbahnen zerfrisst; ist hier aber auch nicht der Fall.

dann würde ich den etwas verlängern und in einem kleinen Plastik-Beutelchen verschwinden lassen.
-War früher bei "nicht-CR2032-Pufferbatterien" in Mainboards quasi Pflicht.
Benutzeravatar
Desinfector
 
Beiträge: 3161
Registriert: Mo 12. Aug 2013, 07:50
Wohnort: FULL PALATINSK

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon shaun » Sa 9. Dez 2017, 00:30

Das Netzteil einfach vom Rest abklemmen scheitert daran,dass der 5V-Ausgang verzweigt über diverse Leiterbahnen und DuKos in den Vcc-Flächen verschwindet.
shaun
 
Beiträge: 2194
Registriert: Mo 12. Aug 2013, 20:37

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon enebk » Sa 9. Dez 2017, 17:08

Richtig. Man könnte natürlich alle Bauteile auslöten und die Spannungsreglerschaltung separat aufbauen... Da überprüfe aber aber lieber zuerst die üblichen Verdächtigen.
enebk
 
Beiträge: 256
Registriert: Mi 14. Aug 2013, 18:51
Wohnort: Marl

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon Bastelbruder » Sa 9. Dez 2017, 17:48

In dieser Primitivschaltung lohnt es sich erstmal die Spannungen an allen Punkten zu messen. 1,4 Volt am Ausgang deuten auf zwei Diodenstrecken und die Schwellspannung der CMOS-Transistoren, das ist genau die Spannung die sich einstellt wenn so eine Schaltung mit bloß wenigen µA versorgt wird.
Bastelbruder
 
Beiträge: 3916
Registriert: Mi 14. Aug 2013, 18:28
Wohnort: drunt' am Neckar - km142,7

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon enebk » Mo 11. Dez 2017, 21:34

Es gibt Neuigkeiten, zuerst der Schaltplan aus dem PX111 mit den nun umbenannten Bauteilen des PX226:
Bild

Bastelbruder hat erneut ins Schwarze getroffen, die im Schaltplan fehlende Diode rechts der Spule war die hinter dem Transistor im Bild.
Letztendlich hat sich D20 in einen Ganzleiter verwandelt, da darf ruhig mal der "Fusistor" kommen. Der Goldcap ist außerdem auch weit von seiner Originalkapazität entfernt. Alle anderen Bauteile waren bisher unauffällig.
Morgen hole ich die Ersatzteile, hoffentlich hat sich damit das Problem erledigt.
enebk
 
Beiträge: 256
Registriert: Mi 14. Aug 2013, 18:51
Wohnort: Marl

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon ferdimh » Mo 11. Dez 2017, 22:42

Damit sollte es nicht erledigt sein. D20 brennt nicht ohne Grund (Überspannung) durch.
Theoretisch wäre Überspannung durch massiv hochohmig gewordenen C6 denkbar, aber eher knapp dimensionierten Überspannungsschutz nach Auslösen "einfach so" zu ersetzen ist irgendwo zwischen Mut und Vorsatz.
Benutzeravatar
ferdimh
 
Beiträge: 5282
Registriert: Fr 16. Aug 2013, 15:19

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon Fritzler » Mo 11. Dez 2017, 22:50

Eigentlich sollte das ganze Fummelkonstrukt gegen einen ordentlichen DCDC Wandler ersetzt werden.
Dann is Ruhe im Karton, auch für die Zukunft.
Wieviel Strom will die Mühle denn auf den 5V?

(Oder direkt ein 230V auf 5V Netzteil verbauen)
Benutzeravatar
Fritzler
 
Beiträge: 4950
Registriert: So 11. Aug 2013, 19:42
Wohnort: D:/Berlin/Friedrichshagen/Am Wasserwerk

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon shaun » Mi 13. Dez 2017, 23:39

Ganz ehrlich: als ich bei so einem Piano Problem mit dem 2SA1643 hatte hatte ich schon ein Meanwell 5V 15W im Gepäck, zum Glück lief es mit dem neuen Transistor (Gerät startete nach Beseitiung einer Goldcap-Havarie unzuverlässig, dann erfuhr ich allerdings, dass man schon länger mehrfach aus-einschalten musste...) dann wieder einwandfrei. DC/DC wäre etwas tricky, die meisten kleinen (Recom 1A im "7805-Look") können nur bis 36V, da müsste man schon eine Serie finden, die 48V aushält - im Piano liegen schnell mal über 30V vor dem Regler an
shaun
 
Beiträge: 2194
Registriert: Mo 12. Aug 2013, 20:37

Re: Reparatur Technics SA-SX226 E-Piano

Beitragvon enebk » Fr 15. Dez 2017, 01:39

Piano läuft wieder. Auch der 2SA1643 war definitiv defekt und kein Händler vor Ort hatte einen passenden Ersatztyp vorrätig. Daher ist jetzt ein DC-DC-Wandler für die 5V-Versorgung zwischengeschaltet (auf LM2596S-Basis, war halt gerade da). Vcc liegt bei mir nie über 28V, die Platine braucht ca. 500-600mA bei 5V, das passt also.
Danke für die Hilfe!
enebk
 
Beiträge: 256
Registriert: Mi 14. Aug 2013, 18:51
Wohnort: Marl


Zurück zu Allgemeine Diskussion

Wer ist online?

Mitglieder in diesem Forum: AlexVR6, Bing [Bot], grobschmied, nero, Skymaxdriver, Yahoo [Bot] und 18 Gäste

span