Wiederaufbau altes Moped

Der chaotische Hauptfaden

Moderatoren: Sven, Heaterman, TDI, Finger

Re: Wiederaufbau altes Moped

Beitragvon Toni » Mo 1. Jan 2018, 17:03

Bild->zoom
Vom Ali https://www.aliexpress.com/item/Cree-XLamp-XHP70-6V-LED-Driver-26MM-DC6V-15V-Input-4500mA-Output-For-XHP70-LED-Light/32627845734.html?spm=a2g0s.9042311.0.0.SuVRXf

Kennt jemand diese LED-Netzteile "LED Driver 26MM Input DC6V-15V Output 6V 4500mA", und hat evtl. eine Schaltplan dazu?
Taugt das was?
Ich möchte den Strom verringern, und einen LED-Übertemperaturschutz ergänzen.
Benutzeravatar
Toni
 
Beiträge: 1073
Registriert: Di 13. Aug 2013, 18:24

Re: Wiederaufbau altes Moped

Beitragvon Bastelbruder » Mo 1. Jan 2018, 18:46

Da sind zwei Widerstände "R120" = 120 Milliohm, das ist der Shunt. Einer raus = halber Strom. Der Wandler tut sich leichter und die Impulse durch die LED werden besser gesiebt wenn man auf die Drossel gleichzeitig ein paar Windungen mehr aufbringt (halber Strom, doppelte Windungszahl).
Bastelbruder
 
Beiträge: 4137
Registriert: Mi 14. Aug 2013, 18:28
Wohnort: drunt' am Neckar - km142,7

Re: Wiederaufbau altes Moped

Beitragvon Toni » Mo 1. Jan 2018, 21:35

Danke.

Habe eben einen Wandler mit einem entfernten R=0,12Ohm an einem Lastwiderstand 2 Ohm ausprobiert: Wandler ist direkt abgeraucht.
Danach habe ich den zweiten Wandler ohne Änderung direkt an der LED probiert: auch abgeraucht :evil:

Entweder die brauchten z.B. noch einen C am Eingang, oder das war schon ab Werk Mist.

Ich werde mir mal Gedanken über einen Low-Drop Linear Stromregler machen.
Die LED braucht 6V, Bordspannung ist ca. 6V-7,2V.
Benutzeravatar
Toni
 
Beiträge: 1073
Registriert: Di 13. Aug 2013, 18:24

Re: Wiederaufbau altes Moped

Beitragvon ferdimh » Mo 1. Jan 2018, 21:45

Wenn die Stromregelung nicht sehr genau sein soll, reicht ein Transistor mit einem gut ausgewählten Basisvorwiderstand. +/-20% in der Lichtausbeute hat auch die Glühbirne...
Benutzeravatar
ferdimh
 
Beiträge: 5426
Registriert: Fr 16. Aug 2013, 15:19

Re: Wiederaufbau altes Moped

Beitragvon Bastelbruder » Mo 1. Jan 2018, 22:02

Eigentlich sehen die nicht schlecht aus. Und der Eingangskondensator ist auch dabei. Steht 0 µF dran. Ausgangskondensator braucht's bei der Schaltung nicht.

Das Einzige was mir suspekt vorkommt sind die 5 identischen MOSFETs von denen drei korrekt parallel angeschlossen sind und zwei irgendwie komisch. Zumindest sind deren Drain-Pins mit Minus verbunden.

Gibts da vielleicht ein Bild abzüglich Magic Smoke?
Bastelbruder
 
Beiträge: 4137
Registriert: Mi 14. Aug 2013, 18:28
Wohnort: drunt' am Neckar - km142,7

Re: Wiederaufbau altes Moped

Beitragvon Sir_Death » Mo 1. Jan 2018, 22:50

Ich stelle mir gerade die Frage, warum du beim Scheinwerfer solche Kopfstände machst, und riskierst, dass das Ding nicht durch den TÜV kommt.
Was wäre damit?
https://www.amazon.de/ba20d-led-Auto-Motorrad/s?ie=UTF8&page=1&rh=n%3A78191031%2Ck%3Aba20d%20led

Jederzeit bei defekt auch unterwegs tauschbar...
Sir_Death
 
Beiträge: 1216
Registriert: Mo 11. Mai 2015, 22:36
Wohnort: südlich von Wien

Re: Wiederaufbau altes Moped

Beitragvon Bastelbruder » Mo 1. Jan 2018, 22:56

Jetzt warten wir noch daß es die Lampe für 6 Volt gibt. Und mit eingebautem Lüfter oder so. Hoppla, der Turbofän ist ja sogar drin! (Aber sehen will!)
Bastelbruder
 
Beiträge: 4137
Registriert: Mi 14. Aug 2013, 18:28
Wohnort: drunt' am Neckar - km142,7


Re: Wiederaufbau altes Moped

Beitragvon tom » Mo 1. Jan 2018, 23:36

nein, das reicht noch nicht !


... "Und die LEDs bitte in Warmton, dass nicht jeder Blaurock auf Anhieb sieht, dass es ein illegaler Umbau ist."
tom
 
Beiträge: 287
Registriert: Sa 19. Okt 2013, 23:17

Re: Wiederaufbau altes Moped

Beitragvon Toni » Di 2. Jan 2018, 01:32

Bastelbruder hat geschrieben:Eigentlich sehen die nicht schlecht aus. Und der Eingangskondensator ist auch dabei. Steht 0 µF dran. Ausgangskondensator braucht's bei der Schaltung nicht.

Das Einzige was mir suspekt vorkommt sind die 5 identischen MOSFETs von denen drei korrekt parallel angeschlossen sind und zwei irgendwie komisch. Zumindest sind deren Drain-Pins mit Minus verbunden.

Gibts da vielleicht ein Bild abzüglich Magic Smoke?


In beiden Fällen hat zumindest einer der 3 parallelen FET's durchlegiert. Danach hat es den vollen Strom durchgeblasen, bis der Shunt das Schauspiel beendete, indem er Evolutionsbremse spielte.


Sir_Death hat geschrieben:Ich stelle mir gerade die Frage, warum du beim Scheinwerfer solche Kopfstände machst, und riskierst, dass das Ding nicht durch den TÜV kommt.
Was wäre damit?
https://www.amazon.de/ba20d-led-Auto-Motorrad/s?ie=UTF8&page=1&rh=n%3A78191031%2Ck%3Aba20d%20led
Jederzeit bei defekt auch unterwegs tauschbar...

Davon scheint es keine mit Stvo-Zulassung zu geben.
Die Dinger hatte ich mir vorher als Inspiration angesehen, und durchweg als ungeeignet für meine Lampe eingestuft (Größe, Kühlung, Lichtstrom, Farbe, Spannung).

Am Scheinwerfer werde ich nichts ändern -> bei Bedarf könnte schnell eine andere Birne+Fassung rein. Umstecken, 4 Kabel umschrauben und fertig.
Benutzeravatar
Toni
 
Beiträge: 1073
Registriert: Di 13. Aug 2013, 18:24

Re: Wiederaufbau altes Moped

Beitragvon Fritzler » Di 2. Jan 2018, 12:04

Also bei 6V Bordspannung wird meine LED KSQ Schaltung mit dem LM2575 langsam etwas knapp (der will min 5V) sowie die Bereitstellung der 5V durch dne 78l05 ird da etwas unmöglich.
-> http://www.fritzler-avr.de/HP/tipps/ksq.php

Aber ich hatte mir mal folgende Schaltun ausgedacht:
Bild
700mA mit dem 0,25R Shunt.
Da wärste aber Versuchskanickel, bisher hab ich die noch nicht aufgebaut.
Benutzeravatar
Fritzler
 
Beiträge: 5043
Registriert: So 11. Aug 2013, 19:42
Wohnort: D:/Berlin/Friedrichshagen/Am Wasserwerk

Re: Wiederaufbau altes Moped

Beitragvon Bastelbruder » Di 2. Jan 2018, 12:24

Der Elko parallel zur LED ist rausgeschmissenes Geld, Platz und Zuverlässigkeit. Lieber die Induktivität noch etwas größer, nur die kann den Strom stabilisieren.
Bastelbruder
 
Beiträge: 4137
Registriert: Mi 14. Aug 2013, 18:28
Wohnort: drunt' am Neckar - km142,7

Re: Wiederaufbau altes Moped

Beitragvon ferdimh » Di 2. Jan 2018, 13:12

Mir macht der Abwärtswandler ja etwas Bauchschmerzen, wenn die LED eine maximale Flussspannung von 6,2V (wie kommt die eigentlich zustande?!) haben soll. Dann wirds möglicherweise ziemlich schnell ziemlich dunkel... Unter Last kann der Bleiwürfel schonmal nur 5,5V haben. Ich würde da eher über einen invertierenden Wandler oder die "12V-Konfiguration" und einen Aufwärtswandler nachdenken...
Benutzeravatar
ferdimh
 
Beiträge: 5426
Registriert: Fr 16. Aug 2013, 15:19

Re: Wiederaufbau altes Moped

Beitragvon Toni » Di 2. Jan 2018, 13:48

ich dachte vom Prinzip her an einen Linearregler in dieser Art:

Bild->zoom

Das ist jetzt einfach schnell aus dem Kopf heraus zusammengeschustert. Hat das Aussicht auf Funktion?
Benutzeravatar
Toni
 
Beiträge: 1073
Registriert: Di 13. Aug 2013, 18:24

Re: Wiederaufbau altes Moped

Beitragvon Fritzler » Di 2. Jan 2018, 13:52

Ach die LED hat 6,2Vf?
Upps :oops:
Benutzeravatar
Fritzler
 
Beiträge: 5043
Registriert: So 11. Aug 2013, 19:42
Wohnort: D:/Berlin/Friedrichshagen/Am Wasserwerk

Re: Wiederaufbau altes Moped

Beitragvon Sir_Death » Di 2. Jan 2018, 13:53

Sieht mir sehr komplex aus die Schaltung.
Wäre eine einfache Transistor-Stromquelle nicht ebenso geeignet?
Sir_Death
 
Beiträge: 1216
Registriert: Mo 11. Mai 2015, 22:36
Wohnort: südlich von Wien

Re: Wiederaufbau altes Moped

Beitragvon ferdimh » Di 2. Jan 2018, 14:00

Das kann man erstmal rundum optimieren.
a) der LM358 kann mit Eingang und Ausgang bis 0V runter (letzteres nur, wenn er Strom liefern muss, das muss er aber...). Er braucht also bei geschickter Beschaltung keine negative Versorgung. Das sollte gehen, wenn man den unteren Opamp als nichtinvertierenden Verstärker beschaltet. (Sollwert an nichtinvertierenden Eingang, Istwert an invertierenden Eingang, dazu ein R-C-Dings vom Ausgang zum invertierenden Eingang).
b) der NPN-Transistor wird eine Restspannung haben, die höher liegt, als die eines MOSFETs. Wenn man irgendwas niederschwelliges findet, sollte das geeigneter sein. Muss sich halt mit 5V aussteuern lassen.
Bei der erwarteten maximalen Uds von 2V sind SOA-Probleme o.Ä. auch bei höchstgezüchteten Leistungsmosfets kein Problem.
c) Du hast doch mal bei einer Servobude gearbeitet. Dann solltest du doch eigentlich wissen, dass man nicht so viel Phasenverschiebung und Verstärkung in einen Regelkreis wie beim Temperaturregler wirft. Ich würde eher den Stromsollwert langsam reduzieren, dass das Ding unauffällig dimmt und nicht Disko macht.
d) Ich behaupte, ein Bipolartransistor mit festem Basisstrom tuts auch.
Benutzeravatar
ferdimh
 
Beiträge: 5426
Registriert: Fr 16. Aug 2013, 15:19

Re: Wiederaufbau altes Moped

Beitragvon Bastelbruder » Di 2. Jan 2018, 15:18

Die Konstantstromquelle Bipolartransistor mit eingeprägtem Basisstrom hat natürlich gerade im Bereich der Sättigung den größten Fehler.

Einen linearen Regler mit unter 100 mV Spannungsabfall für 3,7 V LiIon auf LED habe ich schonmal gepostet, der geht natürlich auch mit 6Volt und da läßt sich problemlos auch die Temperatur verwursten. Bloß die Forenfindfunktion zickt. Ich bleibe dran.

Die Spannungsreserve ist natürlich nicht prickelnd, aber das hätten die abgerauchten Wandler auch nicht geschafft.
Bastelbruder
 
Beiträge: 4137
Registriert: Mi 14. Aug 2013, 18:28
Wohnort: drunt' am Neckar - km142,7

Re: Wiederaufbau altes Moped

Beitragvon Toni » Di 2. Jan 2018, 18:22

danke euch :)

Die Spannungsreserve sehe ich nicht sooo kritisch, aber je kleiner der Drop-Off, desto besser. Mein Ehrgeiz wäre max. 0,2V, aber das realistisch noch verschmerzbare Limit dürfte sogar bei 0,5V liegen.
Das entspricht 5,5V an der LED und 6V aus halbwegs leerem Bleiklotz (=Motor aus). Nur 5,5V an der LED deshalb, weil die da schon ordentlich Licht rauswirft, um zumindest im Stand gut gesehen zu werden.

Bei 2,5A fallen ca. 6V an der LED ab, die braucht's für den Lichtkegel während der Fahrt, und da schiebt die LiMa die Spannung sowieso auf max. 7,2V hoch.
Benutzeravatar
Toni
 
Beiträge: 1073
Registriert: Di 13. Aug 2013, 18:24

Re: Wiederaufbau altes Moped

Beitragvon Toni » Mi 3. Jan 2018, 17:22

@ferdimh: warum hast du mir nicht schon früher gesagt, dass der LM358 am Eingang bis 0V kann ;)

Hier ist ein neuer Versuch. Das Schaltzeichen für ein FET geht mir nicht mehr in die Birne, daher als NPN dargestellt. IRLZ44N habe ich noch herumliegen, die brauchen eine niedrigere Gatespannung.
Die Temperaturbegrenzung wirkt jetzt auf den Komparatorwert der Shuntspannung.

Der Shunt liegt hart auf dem OPV-Eingang -> habe ich dadurch evtl. einen Oszillator gebaut?

Bild->zoom
Benutzeravatar
Toni
 
Beiträge: 1073
Registriert: Di 13. Aug 2013, 18:24

Re: Wiederaufbau altes Moped

Beitragvon ferdimh » Mi 3. Jan 2018, 17:27

Das sieht doch schon besser aus ;-)
Das direkte Koppeln an den Shunt ist prinzipiell kein Problem, möglicherweise brauchts aber noch ein R-C-glied vom Opamp-Ausgang zum invertierenden Eingang, dann muss halt wieder ein Serienwiderstand rein. Ich würde mal auf gut Glück 1k vom Shunt und 10k-10n(in Reihe) vom Gate zum Invertierenden Eingang legen.
Benutzeravatar
ferdimh
 
Beiträge: 5426
Registriert: Fr 16. Aug 2013, 15:19

Re: Wiederaufbau altes Moped

Beitragvon Toni » Mi 3. Jan 2018, 17:43

Du meinst so:?

Bild->zoom
Benutzeravatar
Toni
 
Beiträge: 1073
Registriert: Di 13. Aug 2013, 18:24

Re: Wiederaufbau altes Moped

Beitragvon Bastelbruder » Mi 3. Jan 2018, 18:37

Der Regler sollte so funktionieren.
Eine Gefahrenstelle: Wenn wegen niedriger Betriebsspannung MOSFET und zwangsweise damit verknüpft auch Regel-OpAmp in der Sättigung sind und die Spannung plötzlich ansteigt, dann könnte der beabsichtigte Spitzenstrom durch die LED für kurze Zeit deutlich überschritten werden. Den Fall sollte man zumindest mal simulieren, vielleicht einen PNP-Emitterfolger vorsehen der das Gate vorbei am 100 Ohm? Widerstand schnell runterziehen kann. Wackelkontakte in der Mopedverkabelung sind ja nichts ungewöhnliches.

Die Bremse um den Regler ist eigentlich nicht erforderlich, der Sourcefolger hat keine Spannungsverstärkung. 22 pF reichen aus daß da nichts schwingt.
Bastelbruder
 
Beiträge: 4137
Registriert: Mi 14. Aug 2013, 18:28
Wohnort: drunt' am Neckar - km142,7

Re: Wiederaufbau altes Moped

Beitragvon Toni » Do 4. Jan 2018, 10:13

Danke, ich werde das mal aufbauen. Erstmal ohne Temperaturbegrenzer und ohne RC-Rückkopplung, und schauen was es macht.
Die LED kann bei Kühlung dauerhaft 4,8A ab (kurzzeitig ein Vielfaches). Ich würde daher vermuten, dass die bei vorhandenen Kabelwiderständen nicht durch die Reglerträgkeit im Einschaltmoment zerstört werden kann.

Macht es Sinn, die Versorgung vom LM358 über einen R=100 Ohm (in 6V-Zuleitung) + C=10uF zu dämpfen? Damit der nicht stirbt, falls Spikes auf dem Bordnetz sind...
Benutzeravatar
Toni
 
Beiträge: 1073
Registriert: Di 13. Aug 2013, 18:24

Re: Wiederaufbau altes Moped

Beitragvon ferdimh » Do 4. Jan 2018, 11:07

Ich glaube nicht daran, dass da derartige Spikes auftauchen, aber die Besaftung von Kleinleistungskram über ein R-C zu führen ist eigentlich immer eine gute Idee. Ich würde den C dann halt in Keramik ausführen, dass auch hochfrequenter Kram gut gedämpft wird.
Benutzeravatar
ferdimh
 
Beiträge: 5426
Registriert: Fr 16. Aug 2013, 15:19

VorherigeNächste

Zurück zu Allgemeine Diskussion

Wer ist online?

Mitglieder in diesem Forum: Bing [Bot], Google [Bot], Wurstblinker, Yahoo [Bot] und 16 Gäste

span